Google Scraping Issue
Resolved
Feb 03 at 12:00am CET
We’re pleased to confirm that the ranking issues have been fully resolved. Over the past four days, we’ve closely monitored the performance of our scrapers and can now verify that scraping functionality has been restored to its pre-incident state.
This incident has been a valuable learning experience for our team. Moving forward, we’re implementing additional measures to better anticipate and mitigate the impact of changes on Google’s end, ensuring minimal disruption to our services in the future.
Thank you for your patience and understanding as we worked to resolve this issue.
If you have any questions, please contact our support team at support@keyword.com
Affected services
Updated
Jan 30 at 07:00pm CET
Ranking issues have been resolved. However, as we continue to work through the changes applied by Google, we have noted a delay in keyword processing. This is expected, and while updates may be delayed, your keywords will still be refreshed as scheduled within the day.
When Google makes changes, and we implement the necessary adjustments on our end, it can impact the speed of updates. Our team is actively monitoring the situation and continuously optimizing to ensure your rankings are updated as accurately and promptly as possible.
Affected services
Updated
Jan 24 at 12:10pm CET
We are currently seeing delays in daily updates. This is due to changes we implemented to bypass Google’s blockages, which take longer to fetch ranking results. To ensure accuracy, we have added retry logic to our system. While this improves data reliability, it may result in slower updates. Please expect some delays as we continue to optimize the process.
Affected services
Updated
Jan 23 at 03:25pm CET
We continue to monitor results. While updates are running, users may still experience delays as we further refine our processes and thresholds to minimize disruptions caused by Google’s blocking behavior.
Affected services
Updated
Jan 22 at 09:20am CET
Mobile tracking has been successfully resolved. All updates are now running, though at a slower pace as we fine-tune the system to avoid further blocks.
Affected services
Updated
Jan 20 at 10:00am CET
Desktop keyword tracking continues to be stable, and we are closely monitoring results. The team is actively working on resolving the issue with mobile keyword tracking.
Affected services
Updated
Jan 18 at 08:00am CET
We successfully restored desktop keyword tracking and began processing the queue for desktop updates. Updates are running slower than usual as we intentionally slowed down the queues to prevent further blocks and to better understand Google’s thresholds.
Affected services
Updated
Jan 16 at 10:00am CET
We have identified the root cause of the issue: Google made changes to their search engine results pages (SERP), which affected how ranking data is fetched. These changes introduced stricter blocking mechanisms, requiring adjustments to our systems to comply with the updated Google requirements.
Affected services
Created
Jan 16 at 08:00am CET
We detected the issue affecting all updates as Google began blocking requests, disrupting the ability to fetch ranking data. The team immediately started investigating and working on a resolution.
Affected services