Back to overview
Degraded
Delayed scheduled ranking collection
Feb 21 at 05:00am CET
Affected services
Ranking updates
Resolved
Feb 21 at 03:00pm CET
We are still working on resolving the ongoing issue affecting ranking updates. As a result, no keywords have been updated today.
Once the issue is resolved, we will resume automatic updates and enable on-demand updates as usual. Our team is actively working on a fix, and we will provide further updates as soon as possible.
Affected services
Created
Feb 21 at 05:00am CET
We are currently experiencing issues with the collection of daily rankings. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services