Back to overview
Degraded

Ranking data collection elays

Mar 14 at 09:42am CET
Affected services
Ranking updates

Resolved
Mar 14 at 11:36am CET

Issue has been resolved and updates are being processed as normal. Please expect some delays in receiving today's data.

Created
Mar 14 at 09:42am CET

We are currently experiencing delays in collecting ranking data from Google. Our team is actively investigating the issue and working to resolve it as soon as possible. We appreciate your patience and will provide further updates as we make progress.