Back to overview
Degraded

Google ranking spikes

Mar 19 at 09:00pm CET
Affected services
Ranking updates
Spyglass
Metrics

Resolved
Mar 20 at 03:37pm CET

All historical ranking issues have been fixed.

Updated
Mar 20 at 11:11am CET

We have now updated our parsers to address Google changes and all new ranking updates should be working properly.

Recently broken rankings will also be fixed as soon as possible.

Created
Mar 19 at 09:00pm CET

We've noticed that recent changes to Google's page structure have temporarily affected how our system identified rankings. Our team is working hard to fix the issue, and everything should be back to normal within a few hours. Thank you for your patience!