Back to overview
Degraded
Slow ranking updates
Apr 30 at 01:00am CEST
Affected services
Ranking updates
Resolved
May 01 at 02:00am CEST
Ranking updates issues has been resolved, we're monitoring closely to ensure there are no more related incidents.
Affected services
Created
Apr 30 at 01:00am CEST
We're experiencing temporary issues that significantly slow down our ranking updates, we expect it to be resolved today, tomorrow being the latest.
Affected services