Back to overview
Degraded

Ranking data collection delays

Jan 21 at 11:38am CET
Affected services
Ranking updates

Resolved
Jan 21 at 02:02pm CET

Ranking data collection issues have been resolved.

Created
Jan 21 at 11:38am CET

We are currently experiencing delays in collecting ranking data from Google. Our team is actively investigating the issue and working to resolve it as soon as possible. We appreciate your patience and will provide further updates as we make progress.